Java compiler level does not match the version of the installed Java project facet: Faceted Project Problem (Java Version Mismatch)

Standard

This means the version of a project facet does not match the version of the compiler. I was getting this error on Eclipse Mars. I did the following to fix this:

  1. Open the project properties.
  2. Select “Project Facet” from the left pane.

post1

3. Click on the version beside “Java” facet. Select the one that matches your compiler version.

post2.jpg

For me it was Java 7, so I selected 1.7.

That’s it. The error was gone.

 

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s